Porsche 911 UK Enthusiasts Online Community Discussion Forum GB

Welcome to the @Porsche911UK website. Register a free account today to become a member! Sign up is quick and easy, then you can view, participate in topics and posts across the site that covers all things Porsche.

Already registered and looking to recovery your account, select 'login in' and then the 'forget your password' option.

Wobbly oil pressure...?

Robertb

Yas Marina
Joined
1 Sep 2003
Messages
8,404
The oil pressure gauge on my C4S occasionally has spasms of waving up and down between 3 and 5 before settling again.

Is this a sign of an engine about to blow up, or a dodgy sender or sensor?

Thanks

R.


Migration info. Legacy thread was 121196
 
Bubbles?

Sender or dirty contact I should think. :)

Migration info. Legacy thread was 121197
 
Probably the water in the engine... not something I'm used to!

Migration info. Legacy thread was 121219
 
Robert, does it coincide with variations in engine Revs?

Migration info. Legacy thread was 121222
 
SHould spend quite a bit of time up near 5, especially when accelerating. But generally ranging between 3 and 5 is where it should be.

Robert, bring your car round to mine and I have a drive in it - just to check it for you! :twisted:
I'm all heart! :D


Migration info. Legacy thread was 121238
 
Previous poster said:
Quote: Originally posted by Dr Strange on 28 February 2007

Robert, does it coincide with variations in engine Revs?
No, its usually when I'm cruising at 60-80. Accelerating or backing off seems to make no difference when its having a spasm.

Chris- thanks for your kind offer- I'll bear it in mind!


Migration info. Legacy thread was 121406
 
does it ever drop to 0? Mine did that and then dropped to 0 before coming back up. Turned out to be the sensor.

Migration info. Legacy thread was 121409
 
Previous poster said:
Quote: Originally posted by Robertb on 01 March 2007

No, its usually when I'm cruising at 60-80. Accelerating or backing off seems to make no difference when its having a spasm.
That doesn't sound too great, constant speed usually means constant pressure in mine. As F1 says, could just be a sensor.

Migration info. Legacy thread was 121419
 

New Threads

Forum statistics

Threads
124,584
Messages
1,446,536
Members
49,734
Latest member
11erCharlie
Back
Top