Porsche 911UK Forum

Welcome to the @Porsche911UK website. Register a free account today to become a member! Sign up is quick and easy, then you can view, participate in topics and posts across the site that covers all things Porsche.

Already registered and looking to recovery your account, select 'login in' and then the 'forget your password' option.

Windscreen Washer System - help!

thesmithsUK

Well-known member
Joined
7 Dec 2014
Messages
366
Having read lots of threads on this topic, I went down to my garage this morning full of confidence...

Although my 'intensive' washer system is working fine, the 'regular' one is not. (But both windshield nozzles spraying fine.)

The pump also appears to be working (it's feeding the headlight washers).

I tried disconnecting the relevant hose from the T-shaped check valve under the windscreen bottom (assuming the problem may be with the valve). But, on pumping, no fluid came through the hose!

So I disconnected the hose at the reservoir tank end. (The fluid drained out - albeit rather slowly.)

The hose (now disconnected at both ends) is clear.

Any suggestions on where to go from here?

Am I going to have to pull the reservoir tank? :?
 
If my memory recalls the motor on the little resivour in the frunk supplies the windscreen. My guess would be the motor in that. My motor was all rusted up. I stripped it out of the bottle and cleaned it up. Then all worked fine. The intensive wash has its own pump.
 
Thanks Chief.

Yes, I'm pretty sure the problem is at the tank (/reservoir) end. Could well be the pump. (Didn't realise there are two pumps - one for the headlamps one for the windscreen.)


Just checked the fuse - but this is OK, and shared anyway with the headlamp washing system which is working fine.


Question: do I need to remove the front wing to pull out the reservoir? The pumps are pretty difficult to access in situ...!
 
It will just be the bottle with the red cap on (only small) inside the frunk. The motor is visible pushed into the bottle. I feel pretty sure this will be the culprit.
 
Chief said:
It will just be the bottle with the red cap on (only small) inside the frunk. The motor is visible pushed into the bottle. I feel pretty sure this will be the culprit.

That's the 'Intensive' (silicone) wash bottle, no? That one's working fine. It's the bigger tank that's my problem - underneath the the n/s wheel arch liner.
 
*****!
That'll be the wheel off and arch liner out pal :roll:
 
I dont suppose you have any access to it if you take out the n/s/f headlight ? might only be 993 that you can.

Also was it only on the earlier cars that the pump can also be fitted to the front panel with the pipes going to the bottle in the wing area ?

Either way there is a filter in the bottle which often gets blocked , screen fluid turns to "jelly" over the years .. also stinks to high heaven !
 
Will have another go at the weekend. I don't think I can get in via the headlamp opening but will have another look. Just hoping I don't have to take the wing off...!
 
You cannot get in through the headlight. You will have to get the wheel off then the arch liner. also it might help to get the under panel below the fron P.U off. You can then get to the black resivour. You might find that it's just the connector furred up.
 
Thanks Chief. As I thought.

Grazed knuckles here I come. (Am used to niggling challenges like this as I used to own a TVR!)
 
The saga continues...

So, I disconnected and pulled out the reservoir tank.

I then disconnected the two pumps (one for the headlamps, one for the windscreen) and the water level sensor.

De-scaled / cleaned everything up.

By swapping the two pumps / connectors, I've been able to deduce that both pumps are working fine. The problem is an electrical one!

Now my inexperience is showing...

The diagram inside the fusebox suggests they share a 40-amp fuse which is fine.

The connector itself (at the pump end) looks OK - it's the black one in this photo.

What next?! Any help gratefully received...

7ClHmQm.jpg
 
I take it you swopped the connectors on the pumps and operated the headlight washers and the screen washers then worked ?


The wiper stalk .. its x2 contacts that are pushed together inside the assembly so if it was me i would start there .
 

Attachments

  • washers_1_170.jpg
    washers_1_170.jpg
    565.3 KB · Views: 10,082
Hi Demort,

Yes, swapped the connectors over.

One of the connectors would operate either pump.

One of the connectors would work neither pump!

I didn't think there'd be a problem at the stalk itself (given that it's operating at least one of the connectors)...
 
With the diagram above i would check for an earth to the pump connector (its permanent ) and a feed from the stalk when operated .

The headlight side is operated via a relay whilst the washers come direct from the switch.

There are other connectors along the way so you would check at the pump .. if nothing then check at the switch .. if ok at that point then its a connector from the switch to the pump .

Its the green / red wire that goes to the switch .

EDIT

The diagram shows the black plug with the yellow white wire as the headlamp washer
:?
 
Thanks Demort - will give that a go tomorrow!
 

Latest posts

New Threads

Forum statistics

Threads
124,019
Messages
1,436,379
Members
48,405
Latest member
Rupiah
Back
Top