Porsche 911 UK Enthusiasts Online Community Discussion Forum GB

Welcome to the @Porsche911UK website. Register a free account today to become a member! Sign up is quick and easy, then you can view, participate in topics and posts across the site that covers all things Porsche.

Already registered and looking to recovery your account, select 'login in' and then the 'forget your password' option.

PDK Display problem

sooty

Silverstone
Joined
18 Apr 2009
Messages
107
OK so I might be going mad here but I could have sworn the little window which shows which gear you are in showed a "P","R" and "N" when in Park, Reverse and Neutral but it seems to have disappeared. The gear numbers still show but otherwise it is blank. Am I going mad or do I have to hit something with a hammer? Failing that a trip back to OPC. It is a bit trivial I know but annoying
 

Attachments

  • park_172.jpg
    park_172.jpg
    18.2 KB · Views: 3,839
  • reverse_180.jpg
    reverse_180.jpg
    18.6 KB · Views: 3,839
  • drive_153.jpg
    drive_153.jpg
    18.7 KB · Views: 3,839
Is the little red light next to the P,R,N,D or M illuminating?

And silly question I know but have you turned everything off, got out of the car, locked it, left it a while then started again? (It does work for electrical gremlins sometimes - about the limit of my knowledge I'm afraid; others more expert on here might need that info though).

Good luck.
 
Just the light, never had letters shown in the display on mine.

So yeah, you're going mad ;)
 
Well spin my nipple nuts and send me to Alaska. Thanks for the certification :thumbs:
 
Mine doesn't show any letters, either.

I second Ekona's certification, and as a medical doctor, I can organize for one of my psychiatry colleagues to have you sectioned. Please let me know how you'd like to proceed...

8)
 
No letters in mine. Nice beep for reverse though, or am I hearing things :?
 
Here's the solution for you, Megatron:
 

Attachments

  • auditory_hallucinations_130.jpg
    auditory_hallucinations_130.jpg
    74.9 KB · Views: 3,760
Thanks everyone. I think the rot set in after I sold my 2006 C2S and I discovered why the rear parking sensors didn't work on the C4S. They weren't fitted.

I have been wondering why the lights sometimes come on and sometimes don't when unlocking ( yes, always in be dark). Seems as random as the C2S. What stupid thing am I doing now? The light switch is always on "home"....
 
Megatron said:
No letters in mine. Nice beep for reverse though, or am I hearing things :?

I think you only get the beep if you have the rear parking sensors.
 
sooty said:
I have been wondering why the lights sometimes come on and sometimes don't when unlocking ( yes, always in be dark). Seems as random as the C2S. What stupid thing am I doing now? The light switch is always on "home"....

I have wondered the same thing... I wonder whether it's to do with the battery's charge-level.
 
It is real...

Actually, I had the same issue with my 2012 997 GTS. The little display, next to the leds was display 1-7 but also P, N and R.

The other day suddenly I realised that it has stopped displaying P, N and R, although 1-7 still are displayed correctly in manual and automatic mode...it is really puzzling...

Any ideas?
 
I'm sure that I'm not crazy (at least about this topic :wink: )

Seriously, I'm a bit concerned that my car might be developing an issue... I was having R, N and P displayed as well as the 1-7 all the time, and suddenly the display is blank when I engage parking, neutral or reverse...

Anyone else have a clue about what is going on here?
 
Another vote for "crazy". Mine has never displayed letters, only the number of the gear. :bonk:
 

Forum statistics

Threads
124,310
Messages
1,444,031
Members
49,439
Latest member
markt13
Back
Top