Porsche 911 UK Enthusiasts Online Community Discussion Forum GB

Welcome to the @Porsche911UK website. Register a free account today to become a member! Sign up is quick and easy, then you can view, participate in topics and posts across the site that covers all things Porsche.

Already registered and looking to recovery your account, select 'login in' and then the 'forget your password' option.

PCCM Plus - DAB/Radio issues

X911

Silverstone
Joined
7 Oct 2021
Messages
128
Hi all

First post although Ive been following the forums for some time now.

Have just become the owner of a 2003 C4S in Artic Silver, will upload some pics when I get an opportunity.

First modification was to install the PCCM Plus which I must say is a fantastic addition and really brings the car into the 21st Century. The car came with PCM2 and MOST with Bose speakers.

The install went very smoothly and took me perhaps a couple of hours until I got to the radio part of the install. I had the DAB box wired up but was only getting limited FM stations and no DAB. Consulted the forums and figured out that I needed to bypass the Diversity Control Module and the windscreen antenna amplifier. Both these parts caused me by far the most difficulty of the entire install ( and I opted to install the microphone in the factory location which meant taking out the entire instrument cluster).

I got the first connector (the double connector) out of the Diversity Control Module in the passenger footwell, however, the single connector was much more difficult to access and I must have spent 45 minutes trying to wrestle it out of its connector. Eventually I managed it. I connected one of the double connectors to the single one using the supplied blue cable.

Moved on to the windscreen antenna amplifier and similar problem there, the connecter (I removed the bottom one which I understand is the main antenna) simply wouldn't shift out of the holder! Again, eventually managed to get it free and connect up the by pass cable supplied with PCCM Plus. I connected the gold end of the supplied connector to the mustard/yellow coloured connector on the windscreen antenna amplifier and the grounded it using one of the two screws that secure it to the body of the vehicle. With that, the install was complete, or so i thought! :pc:

I am still getting limited FM and DAB stations. Sometimes I get a decent sized list of DAB+ stations (it still seem to be missing the BBC stations on DAB+) but then it drops out again. When I can get a list of stations up the audio quality is poor with quite prominent static noise behind the main audio from the station.

Anyone had similar issues and managed to resolve or have any ideas what the issue might be?

I am sure that I have installed everything correctly (having followed multiple forum threads and the dealer instructions) but clearly something isnt right. Only thought I have is that I could try connecting to the other connector on the windscreen antenna amplifier (the top one which I believe is the diversity?) but no idea if this is the problem, just simply guessing.

Any help here would be much appreciated!

Thanks
Danny
 
I have what seems to be be a weird issue. When the car is stationery everything is fine but when in motion DAB / FM / AM all seem to struggle keeping a consistent signal and the output sound fades in and out. It doesn’t seem to be related with the location / driving path. Rest of the functionality of the pccm plus unit seems to be operational as expected. Recently acquired 996 Turbo S 2004 with BOSE (CD Changer and AMP in front trunk)

Any suggestions/checks ? Read a thread about the wrong connections and loop back in the antenna piece etc. Wanted to see if anyone else has experienced a similar issue before I start dismantling things…

Thanks
 
I have what seems to be be a weird issue. When the car is stationery everything is fine but when in motion DAB / FM / AM all seem to struggle keeping a consistent signal and the output sound fades in and out. It doesn’t seem to be related with the location / driving path. Rest of the functionality of the pccm plus unit seems to be operational as expected. Recently acquired 996 Turbo S 2004 with BOSE (CD Changer and AMP in front trunk)

Any suggestions/checks ? Read a thread about the wrong connections and loop back in the antenna piece etc. Wanted to see if anyone else has experienced a similar issue before I start dismantling things…

Thanks
Mine had poor DAB reception and found the cable pin out to be wrong in passenger footwell, maybe it was my comments you found. Was easy to diagnose with a multimeter.
 
Have you installed a new DAB antenna?
 
Mine had poor DAB reception and found the cable pin out to be wrong in passenger footwell, maybe it was my comments you found. Was easy to diagnose with a multimeter.
Searching for that. It seems to be a common problem (new head unit make-model agnostic).
 
Have you installed a new DAB antenna?
I will find out if I have to open it up. I only tested the Radio / DAB+ when stationary and switched to testing Car Play so it’s sort of slipped under the radar.
 
Read a thread about the wrong connections and loop back in the antenna piece etc. Wanted to see if anyone else has experienced a similar issue before I start dismantling things…

I also had this issue, the pinout was wrong on the plug in the passenger footwell (uk rhd car). Took about 10mins to swap it over and no need to remove the head unit
 
I also had this issue, the pinout was wrong on the plug in the passenger footwell (uk rhd car). Took about 10mins to swap it over and no need to remove the head unit
That’s good to know, so I am in the same boat - UK RHD car. Would you be able to point me to the thread / instructions / any photos please ?
Do I need to buy anything or just swapping existing cables ? Many thanks.
 
Many thanks. Is that diversity module sat in the area behind the glove box, passenger footwell end, there seems to be padding three plastic screws or further towards the firewall or is it behind or between the footwell area and the rear of the centre console lower part within the side ?
 
Many thanks. Is that diversity module sat in the area behind the glove box, passenger footwell end, there seems to be padding three plastic screws or further towards the firewall or is it behind or between the footwell area and the rear of the centre console lower part within
 
No its on the near side between dashboard and wing not bulkhead. Does this pic help?
 

Attachments

  • Screenshot_20240423_201708_Nextcloud.jpg
    Screenshot_20240423_201708_Nextcloud.jpg
    1.3 MB · Views: 21

New Threads

Forum statistics

Threads
124,294
Messages
1,443,885
Members
49,411
Latest member
CurtisN2804
Back
Top