Porsche 911 UK Enthusiasts Online Community Discussion Forum GB

Welcome to the @Porsche911UK website. Register a free account today to become a member! Sign up is quick and easy, then you can view, participate in topics and posts across the site that covers all things Porsche.

Already registered and looking to recovery your account, select 'login in' and then the 'forget your password' option.

Loss of power/engine stutter

perrin996

Monza
Joined
9 Jul 2011
Messages
218
Hi

Was out driving my car today and all was ok after some steady town driving and a few quick blasts but then as I accelerated away from a roundabout the car just seemed to stutter then after a few seconds went off like a rocket.
I then drove at mixed speeds for 20mins with no problems.

Just wondered if anyone has had this before.

996 3.6 c2

Steve
 
Could be lots of things.

A coil pack on it's way out. Is one of those possibles (unless they've been changed recently).

Putting a laptop on it might show a fault code.
 
Hi,

Have the MAF checked, it may be on it's way out. Better to have it checked and fixed rather than have it fail on you. Hope i am wrong though.

Regards

Vinny
 
coil pack

I agree with Storm996 on the coil pack possibility. :judge:
 
I had a similar problem that took some getting to the bottom of after I'd changed all the coil packs and checked a few other things. A spark plug that was only a year old had started to breakdown and was showing no codes, swapped the faulty one for a used one and it ran fine, just got to fit 6 new plugs this weekend to make sure it doesn't happen to another one.
Get it plugged into to double check its nothing else though.
 

New Threads

Forum statistics

Threads
124,813
Messages
1,448,842
Members
50,012
Latest member
steviepee
Back
Top