Porsche 911 UK Enthusiasts Online Community Discussion Forum GB

Welcome to the @Porsche911UK website. Register a free account today to become a member! Sign up is quick and easy, then you can view, participate in topics and posts across the site that covers all things Porsche.

Already registered and looking to recovery your account, select 'login in' and then the 'forget your password' option.

Instrument cluster missing Pixels

andy67

New member
Joined
14 Jan 2016
Messages
37
As per the title, my 996 3.4 c4 (2001) has started to lose a few pixels within the instrument cluster, I'll try and upload a picture at a later date. Does anybody know of who/where I could get the cluster repaired? I'm not that great with the spanners so removing the instrument cluster might be beyond my abilities. I'm in the northwest, Stockport. I did try looking through the forum but couldn't find anything.
Thanks in advance
 
I used Autotronics, www.autotronics.co.UK for the repair of my cluster as the centre LCD would go dark when it warmed up.


They did a very good job and alls good now.
Took about two weeks though waiting for parts etc.
Total cost £200.

As far as removing the cluster it's really not too difficult.
It's only held in place by two screws, one behind the microphone cover and the other behind the hazard flasher switch.
Have a look on YouTube for some videos.

:D
 
stewhp said:
I used Autotronics, www.autotronics.co.UK for the repair of my cluster as the centre LCD would go dark when it warmed up.


They did a very good job and alls good now.
Took about two weeks though waiting for parts etc.
Total cost £200.

As far as removing the cluster it's really not too difficult.
It's only held in place by two screws, one behind the microphone cover and the other behind the hazard flasher switch.
Have a look on YouTube for some videos.

:D

Thanks Ill have look at them
 

New Threads

Forum statistics

Threads
124,576
Messages
1,446,480
Members
49,724
Latest member
markevo6
Back
Top