Porsche 911 UK Enthusiasts Online Community Discussion Forum GB

Welcome to the @Porsche911UK website. Register a free account today to become a member! Sign up is quick and easy, then you can view, participate in topics and posts across the site that covers all things Porsche.

Already registered and looking to recovery your account, select 'login in' and then the 'forget your password' option.

Help with Loss of power, over revs - FIXED NOW

msaif996

Monza
Joined
8 Dec 2010
Messages
195
Hello all, I just collected from car (2002 996.2 6MT with 85k miles) from my local OPC where it had a service. It was running right but when I stopped and then drove off again the below happened:

Engine racing at idle which is now 1,200RPM
No power when accelerating (it feels like I’m driving my first car again, a Ford Fiesta 1.1 back in 1992!)
Revs drop when driving
The exhaust noise is higher than usual, both at idle and when driving. The sound now with the PSE off is really loud

The only other thing is that the OPC told me the DME had a fault but they said it went away and they did not see any issues with the car.

The car is at the OPC now. Any ideas on what is going on would be appreciated.

Thank you
 
Last edited:
any dash messages when the issue occured? how are the coil packs ?
 
No dash nights. I’ve owned the car for nearly 20 years and I can’t recall coil packs being specifically changed. It does have a full OPC service history and I wonder whether coil packs are changed as part of a service I’ve had. I’m still waiting for the OPC to call me.
 
Good news, I just heard back from my OPC and it was ‘an issue with oil pressure and they found a faulty oil pressure switch. They also cleaned the air mass sensor and tested the car’.
That’s such a relief.
 

Forum statistics

Threads
124,561
Messages
1,446,372
Members
49,702
Latest member
deonj
Back
Top